All Collections
Reporting Engine
Reports — Creating a Standard Table Report or a Pivot Table Report
Reports — Creating a Standard Table Report or a Pivot Table Report

This article shows you how to navigate the reports menu and organize reports as well as how to create a standard or pivot table report.

Updated over a week ago

Overview

Pipeliner offers a comprehensive reporting facility which is easy to work with and uses the same options - e.g. Filters - that you'll see and use elsewhere throughout the application.

There are three main types of report that you can create:

Standard Table - a spreadsheet-style report with fully selectable columns, grouping and sorting as well as an option to embed charts (and then display those embedded charts on Dashboards). Standard reports are built on a single Record Type but can also include information from related records - for example, an Opportunity report can include information about the Products associated with each Opportunity. For more detail on how to add related record information, click here. ⤵

Pivot Table - pivot table reports allow you to select multiple rows and columns and to add additional breakdowns within each column (values). You can embed charts (and then display those embedded charts on Dashboards). Pivot table reports are built on a single Record Type but can also include information from related records - for example, an Opportunity pivot table report could display the "count of" and "sum of values" for Opportunities at each Sales Step by Industry (an Account field). ⤵

Advanced Table- advanced reports are designed for complex views of related records. The Report Builder allows you to add multiple sub tables displaying information related to your main Record Type. Advanced reports are only available for Enterprise and Unlimited Tier customers. ⤵

Reports can be private to the creator or can be shared with other users. The data from reports can be exported to Excel/csv or printed to pdf. Reports can also be emailed out (subject to the user having an active email integration) and, if you're an Enterprise or Unlimited Tier customer, they can also be sent out via email on a defined, regular schedule. This article has more information.

You'll also see the option to add Dashboards from the Create New menu. Click here for more information on creating Dashboards - and the report charts that are used in them.

Helpful Hints:

  • Reports are dynamic which means that as you change information in Pipeliner, the Report that contains that information is automatically updated with the latest ("now") information.

  • Depending on their User Role, a Pipeliner user can create Reports and share Reports with others. Note that different users might see different data when using the same report as the information they have the rights to see is also based their User Role.

Accessing Reports

Click on the "Analytics" menu and then "Reports" ⤵

Existing reports will be displayed in the left hand panel. Click on any report to display it in the main pane ⤵

Search for a report by name using the "Search" box or filter the displayed reports using the dropdown options ⤵

NOTE: clicking on the gear icon next to the filter dropdown allows you to hide empty folders.

Creating a New Report

Click the "Create New" button ⤵

You then have 2 choices:

  • Report - your new report will be created based on the entity (Record Type) you select in the next step and the data initially visible in the report will be based on the "My" profile for that record type (i.e. only records you own and those to which you have been explicitly added as an Editor/ Watcher). The columns (fields) included in the report will be a subset of system (out-of-the-box) Pipeliner fields only.

  • Report from Profile - your new report will be created based on the entity that your selected Profile applies to (i.e. if your Profile is for Opportunities, your Report will automatically be based on Opportunities). The data initially visible in the report will be based on the selected Profile. If you have customised the List View for the selected entity and saved your changes to the Profile, the columns (fields) included in the report will reflect your previously selected choices.

NOTE: you can use the Report from Profile option to build reports based on the main system entities (Leads, Opportunities, Quotes, Accounts, Contacts, Activities, the Archive and Projects. If you want to build a report based on Products, you must use the Report option and then select Products as your "Record Type".

Once you've chosen Report or Report from Profile, the next step is to give your new report a Name (this can be changed later). You can also add a Description - do this if you're going to be sharing your report with other users so they're clear on what the report is designed to show them. Your report will be placed in the "All Reports" folder by default, change this from the Folder dropdown. Select the Record Type from the dropdown list (if you chose Report from Profile, this will already be pre-set) ⤵

Finally, choose the type of report you want to create (Standard Table, Pivot Table or Advanced Table) and and then click the "Create" button ⤵

Working with a Standard Table Report

Once your Standard Table is created, you can then decide how to format it, which columns to include, what filters to apply, whether to apply grouping/sorting, what totals to use as well as create an embedded chart.

Re-ordering columns can be achieved by dragging and dropping within the main pane and sorting simply by clicking on a column header but most changes will be made by clicking on the Settings button ⤵

The View Tab

Having clicked on the Settings button, by default you'll be on the the "View" tab. Use the options under the View tab to modify the columns included in your report, set up grouping and sorting and select how Totals are displayed as well as convert reports into a different type and create a chart.

The first option you'll see is the ability to convert your report from a Standard Table to a Pivot Table (or Advanced Report for Enterprise/Unlimited Tier customers) ⤵

NOTE: this option to "Convert To" can be useful if you've worked on a Standard Table and then decide that a Pivot Table view of the same data would also be of value. What we'd recommend is that you "Copy" your existing report - either from the main menu button or by clicking on the gear icon next to the report name in the left hand panel and choosing "Copy". This way you retain your original report and can then convert the copy ...

Modifying the columns included in your report

Under the "Visible Columns" section, you'll see all columns (fields) currently included in your report. To add a new column, click into the search box and either select the field by scrolling down through the available sections ⤵

or type the first few letters of the field name into the search box and select from the options presented ⤵

Alternatively, to the right of the Columns heading, click on the "Choose" button ⤵

You can scroll through the list or search by field name and select the columns you would like to add to your report by selecting them from the left hand "Available columns" section and moving them into the Displayed columns section on the right by using the “+” symbol next to the column name ⤵

If there are any columns you do not want to see in the report us the ”” symbol next to the name of the column in the Displayed columns section ⤵

Then click on "Save".

You can also remove columns from your report by clicking on the x beside the field when hovering over the field in the list under "Visible columns" ⤵

Other options available by hovering over a field allow you to align the text (left, right or centre) or colour code the column to highlight the data ⤵

Scrolling further down brings you to the Grouping and Sorting sections and options for using Totals within your report. These are described in more detail here.

The Role Tab

The options under the Role tab determine which data is displayed in the report based on Ownership and Sales Unit access (rather than Filter criteria).

If you create a report by selecting the Report option from the "Create New" button, your new report will automatically be based on the "My" profile for the Record Type you've selected. The "My" profile is set up to display records that you are the Owner of and records to which you have been explicitly added as an Editor or Watcher.

The options that you'll see checked by default are:

  • Show my items - records you own

  • Show items of my sales team(s) - records you're an Editor or Watcher on

If you need to see all data (that you have rights to view) in your report, you will need to also select:

  • Show items of my sales unit(s) - all other records that your user role gives you the rights to view ⤵

The Filter Tab

Having ensured that all options are ticked under the Role tab, switch on filtering in the Filter tab to modify the data displayed in your report. Details of working with Filters are described here. ⤵

The Target Tab

When you are working with an Opportunity report, you'll also have access to the Targets tab.

Switching on "Target" will add a section at the top of the Standard Table report which will display the same Target values that you'll see in the Target in the Opportunity main menu view. This article describes the values and settings in more detail.

It's important to set the Target Source correctly - this will default to "My Opportunities" if you created the report using Create New>Report and you'll usually want to ensure this is changed to "All Opportunities" ⤵

NOTE: the Target values displayed in the Target section are governed by the Target Tab>Target Period not by any periods you might have included in date fields in your Filter criteria under the Filter Tab.

Working with a Pivot Table Report

Once your Pivot Table is created - either by creating a new Pivot Table or by converting from an existing Standard Table report - you can then decide which fields to use in Rows and Columns and which Values to include as well as Role settings and what Filters to apply as well as whether to create an embedded chart. ⤵

The View Tab

Click on the Settings button to open up the View tab which allows you to:

  • Convert your Pivot Table to a Standard Table (or Advanced Table for Enterprise or Unlimited Tier customers)

  • Select the Rows and Columns you want to use in your report

  • Decide on the Values and aggregation functions you want to apply to them

  • Confirm additional options such as where Totals appear and which columns should appear when clicking on a value using the drill down

Click into Rows and Columns to select which field(s) to use in your Pivot Table. Reorder the selected fields by dragging and dropping so that the report is formatted to get the output you need. In the example below, the Row data is displayed first by Sales Unit and then by Opportunity Owner and the Column selection is Opportunity Status so you'll see a column for "Open", "Lost" and "Won" ⤵

Now you need to decide on the Value - or Values - to be displayed for each Row and Column. In this example, the Values displayed are the default "Count" of "Leads & Opportunities" which will give us the number of Opportunities for each row and column and the "Sum" of the "Opportunity Values" for each row and column ⤵

Hovering over the field in the Values list allows you to access the gear icon which opens up the Value Configuration box. You can change your selected field from the "Field Name" dropdown if required. In the "Value Label", you can replace the default with a custom name that will then display in your report ⤵

"Summarize By" is available when you've added more than one value. Choose from Count, Average, Sum, Min or Max

Switch on "Compare To (as %)" to compare values inside your pivot table and represent the comparison as a percentage instead of the absolute value ⤵

Choose from the following options:

  • Row Total - takes the value that is in the Row Total cell and compares it to the value in the pivot table cell and the value is displayed as a %

  • Column Total - takes the value that is in the Column Total cell and compares it to the value in the pivot table cell and the value is displayed as a %

  • Grand Total - takes the value that is in the Grand Total cell and compares it to the value in the pivot table cell and the value is displayed as a %

  • Other Value - you can choose another field to compare your pivot table value to which is then displayed as a % ⤵

Examples of comparisons that you might want to use are:

  • Won amount vs Total Sales Amount

  • Count of leads vs Total Count of Leads

Next, you can decide where you want Totals to appear ⤵

Finally, choose the Fields you want to display in the List View when you drill down into any of the values in your Pivot Table. Click on the drop-down list or click the "Choose" button to see the columns you currently have and select from there ⤵

Using Drill Down in Pivot Tables

Click on any value in your Pivot Table to drill down into the underlying details ⤵

The results will open in a List View with all of your previously selected fields as columns ⤵

Selecting individual records or all records in the list allows you to carry out a selection of bulk actions.

How to organize your reports into folders

Creating folders that Reports to store your reports in makes them easier to organise and find. Select the "Create New" button, then "Folder" ⤵

Name the new folder and click "Save". You can drag and drop reports into a folder ⤵

Or you can click on the gear icon to the right of the report name and choose "Move To" from the available options ⤵

Next, select the folder you want to move the report to and click on the "Move" button.

How to change Ownership of your report

If you create a report on behalf of a colleague, Ownership of the report (and any scheduling options associated with it) can be reassigned using the Ownership button. The new owner will then have the rights to modify the report directly as required. ⤵

How to share your Report with others

Once you create a Report, no one else can see it unless you share it with them. To share a report, click the "Report Settings" in the upper right of the Report. Select the drop-down next to private and select the "Custom" to share it with specific Pipeliner users on your team, or Public to share the Report with all Pipeliner users ⤵

Frequently Asked Questions (FAQs)

How do I choose which pipelines I want to report on?

When you create an Opportunity report, you can change the pipeline(s) the report is based on by clicking on the Settings button and then making your selection from the Current Pipeline section ⤵

If you create a new report using "Create New>Report" your report will be based on All Pipelines by default whereas if you use "Create New>Report from Profile" your report will be based on the pipeline associated with your Opportunity profile. Change these default settings by selecting or unselecting pipelines in Current Pipeline.

How can I see more of my report?

If your report contains a lot of fields, you can close off the left hand panel by clicking on the chevron ⤵

Did this answer your question?